Excel Construction Kit #1
Year Planner Application

In this book you will learn how to use and apply advanced Excel skills to construct this robust Excel
business application:
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Learning by doing.
An alternative approach to learning and applying Excel skills

For over 900 years craftsmen have traditionally taught their skills to an apprentice. The apprentice would
work (often unpaid) for a period of five to nine years to learn the craftsman’s trade. In this model the
apprentice learned his trade by observing how the master craftsman used his skills. The apprentice would
then attempt to imitate the same techniques.

This construction kit will teach you advanced Excel skills in the same way. Even if you only have basic Excel
skills, the construction kit is designed in such a way that you’ll be able to construct a complex, polished
professional Excel application that would be well beyond the powers of most advanced Excel users.

As you progress through the book you will use advanced Excel skills to construct a finished application.
Along the way you’ll learn Excel techniques that you will be able to apply in the future to a multitude of
Excel business problems.

No VBA program code or Macros are used in this construction project.

Add-  Eyé COM
i Rdd-ins Awd-ins

Add-ins

acr

The use of VBA programming code or recorded macros (recorded macros also contain VBA program code) is
always a virus threat. For this reason, most corporate environments have a security policy that does not
allow VBA program code within Excel workbooks.

When using Excel for its intended purpose it is actually very rare find a true need for custom VBA program
code.

No VBA program code, recorded macros or add-ins are used in the sophisticated project you'll build using
this book. You will complete your construction kit using only regular Excel features.

This book will teach you best-practice when applying your Excel skills
to large real-world projects.

This book won’t only teach you Excel skills. You'll also learn a best-practice design and development
methodology that will stand you in good stead when working on future Excel projects.

In constructing this project you'll discover new and interesting ways to use many of Excel 2019’s more
powerful and complex features.

Use of this book as courseware

This book is particularly useful for training organizations, teachers, schools, colleges and universities who
would like to engage, motivate and interest students by having them use Excel skills to produce an
interesting, useful and impressive Excel application.



You can use this construction kit in two ways

As an Excel beginner

If you are an absolute beginner who has never used Excel before you'll need to acquire some basic skills
before beginning this construction kit. We offer a free Excel Basic Skills tutorial on our thesmartmethod.com
website as a free e-book and on-line video. This covers the bare minimum skills you’ll need to get started.
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FREE book

If you follow this track, you'll still learn a lot of useful information (and hopefully have fun along the way),
but you'll only have a surface-level understanding of some of the Expert-level skills you'll use. You'll also
have a more limited knowledge of Excel as you'll only discover the features that you use in the construction
kit.
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Calendar and Year Planner
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Useful for reference

It isn’t necessary to have the Essential Skills and Expert Skills books (or e-books) on hand to complete this
construction kit but it is highly recommended that you do.

The Essential Skills and Expert Skills tutorials provide an in-depth understanding of all the advanced features
used in this construction kit. If you have the books (or e-books) on hand, you’ll be able to use them as a
reference to expand your understanding of some of the advanced skills you will use in this construction kit.

As an Excel Expert

If you've already completed our Essential Skills and Expert Skills tutorials you already have advanced Excel
skills that are rarely mastered by the average user.

This construction kit will show expert users how to plan and implement a high-quality Excel solution. You'll
learn a solid design methodology that will enable you to use and apply your skills to satisfy even the most
complex business requirements.

You will also discover some innovative techniques that combine Excel’s advanced features to elegantly solve
complex requirements.
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Every step in your construction kit is presented on two facing pages

Pray this day, on one side of one sheet of paper, explain how the Royal Navy is prepared to meet the
coming conflict.
Winston Churchill, Letter to the Admiralty, Sep 1, 1939

Winston Churchill was well aware of the power of brevity. The discipline of condensing thoughts into one
side of a single sheet of A4 paper resulted in the efficient transfer of information.

A tenet of our teaching system is that every step in this construction kit is presented on two facing sheets of
A4. We've had to double Churchill’s rule as they didn’t have to contend with screen grabs in 1939! If we
can’t teach an essential concept in two pages of A4 we know that the subject matter needs to be broken into
two smaller lessons.

How this book avoids wasting your time.

Many presentational methods have been used in this book to help you to skip reading about things you
already know how to do, or things that are of little interest to you.

Lessons are logically grouped into
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Learning by participation

Tell me, and I will forget. Show me, and I may remember. Involve me, and I will understand.

Confucius, Chinese teacher, editor, politician and philosopher (551-479 BC)

Confucius would probably have agreed that the best way to teach IT skills is hands-on (actively) and not
hands-off (passively). This is another of the principal tenets of The Smart Method® teaching method.

Research has backed up the assertion that you will learn more material, learn more quickly, and understand
more of what you learn if you learn using active, rather than passive methods.

For this reason, pure theory pages are kept to an absolute minimum with most theory woven into the hands-
on lessons, either within the text or in sidebars.

This echoes the teaching method used in Smart Method classroom courses where snippets of pertinent
theory are woven into the lessons themselves so that interest and attention is maintained by hands-on
involvement, but all necessary theory is still covered.

Session Three: Advanced Functions

Whenever something can easily go
As Johnny scored 70% the result is FALSE (as 70% is not less . .
than 60%). If Johnny had a percentage score of less than 60%, Wrong/ or When the SUb]eCt text is
the function would have returaed the text “Fall’ L particularly important, you will see the
important sidebar. You should always
read important sidebars.

Note that textual values must be placed in double quotation

Logical_test1 | Bd<60% X 3 -
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Value_if_truel  “Fail” ) 5
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Excel recognizes text 3 USE the IFS function to calculate the grade for each student A goal of this book is not to waste your
as having a value in using the grade data dsfined in cells E3-F8 time by explaining any skill twice.
logical expressions i . .
gleslexe 1. Deletehe functions in column C. Sometimes you may forget something
If you trv entering text into the 2. Addanew IF5 function to cell C4.

that has already been covered earlier in
the course.

Percentage column you might be

surprised to find this result 3. Enter the following pair of Logical Test/Value arguments:

3 |Name : \‘w'!\l"i\hl’f' Grade I-Dglcal_m‘ B4>SESS 1

ey cre_tmecp 2 Value if_truet | Fail e Cross-references are extensively used
Excel has evaluated this logic Notice the t1se of an absolute reference for cell E5. This is pointing you back to the lesson in
expression needed to make sure that the formula AutoFills correctly. / which the relevant skills was learned
="teacup”=90% If you do not understand absolute references see: Lesson 1-10: ’
.. and has surprisingly Add percentage and runming tatals using Quick Analysis (sidebar). The cross-references also help when
saister=E LALE 4. Add appropriate Logical Test/Value pairs for the other grades. you use this course as a reference book
This seems. zling at first N . .
a1t 19 reslized thot (betund 5. Click the OK button. but have forgotten the more basic skills
the scenes) Excel does assign 6. Autofill cell C4 down to the end of the range. needed to Complete each step
values to text in order to °
implement alphabetical sorting. Exactly the same grade values are now shown. The difference

. . from the first approach is that the grades will change if the

Ee::\g;\lx‘n;l&:lx:;‘aﬁmﬂ Percentage/Grade thresholds shown in cells E3.F8 change in
50 that (in an A-Z sort) the future.
i b | i e 4 Save your work as IFS Grades-2.
before text
To work around this peculiarity

you could add a new first
Logical Test/Value pair to ensure
that the value in column B was
numeric like this:

Logical_test! | ISNUMBER[B4)=FALSE
Value_if_true1  “Error
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What you will learn

In the process of completing this construction kit, you'll learn how to apply many Excel skills in the context
of a real-world project.

Here are some of the skills you will use (in the order that they first appear in the book).
Understand the Waterfall Method.

Understand update channels and enable automatic updates.
Apply background colors.

Specify a custom color using RGB values.

Create a Custom Color Set.

Enable and disable gridlines.

Apply Borders and Lines.

Select non-contiguous cells, rows and columns.

Resize rows and columns.

Use AutoFillL

Set vertical and horizontal cell alignment.

Set cell indents.

Set font sizes and colors.

Wrap text.

Merge cells.

Use custom formats.

Create line breaks within custom formats.

Insert Symbols into cells.

Insert pictures into a worksheet.

Use a Spin Button Form Control.

Use a Checkbox Form Control.

Insert and name worksheets.

Create a Tables.

Name a Table.

Apply Cell Styles.

Work with shapes.

Define named ranges and named cells.

Use the Name Manager to view, delete and edit range names.
Create a drop-down list using a list validation.

Understand and use control settings.

Understand and use helper cells.



AutoSize columns.

Use the IF logical function.

Understand Date Serial Numbers.

Use the DATE function.

Understand international date formats (MDY and DMY).

Use the WEEKDAY function.

Understand precedence rules.

Format date serial numbers using a custom format.

Use the TEXT function.

Use the UPPER function.

Use a cell link to connect a Spin Button control to a control setting.
Understand magic numbers.

Create a formula driven conditional format.

Use the MONTH function.

Use the Conditional Format Rules Manager.

Use the OR logical function.

Understand the AND, NOT and XOR logical functions.

Use absolute, relative and mixed cell references.

Calculate the correct date for New Year’s Day (in any year) using the DATE function.
Link a table of fixed events to the calendar so that fixed events are appropriately displayed.
Use the VLOOKUP function.

Use the IFERROR function.

AutoFill formulas.

Copy and Paste.

Understand calculated table columns.

Calculate the correct dates for New Year’s Day, Independence Day, Christmas Day and Veterans’ Day
(for any year) using the DATE function.

Calculate the correct date for Martin Luther King Day, President’s Day, Labor Day, Columbus Day and
Thanksgiving Day (in any year) using simple Excel formulas and helper cells.

Understand the CHOOSE function.

Calculate the correct date for Memorial Day (in any year) using simple Excel formulas and helper cells.
Understand symbolic constants and how they can be used to give meaning to magic numbers.
Calculate the correct date for Easter Sunday (in any year).

Add a unique constraint to a table using a formula-driven data validation.

Understand the COUNTIF and COUNTIFS functions.

Use structured table references.



Use the CHAR function.

Understand the CODE function.

Concatenate text.

Create a text length data validation.

Calculate the age of the moon using Synodic Months and the MOD function.
Calculate the correct phase of the moon (for any date) based upon the moon’s age.
Use the ROW function.

Use Excel’s zoom feature.

Use Paste Formulas to copy formulas without disturbing conditional formatting.
Create user-friendly validation error messages.

Hide error warning markers.

Use Smart Tags.

Unlock cells.

Hide columns and entire worksheets.

Protect a worksheet to prevent users from making unwanted changes.
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Introduction

Introduction

Welcome to Excel 2019 Construction Kit #1: Calendar and Year Planner. This book has been designed to enable
students to apply their existing advanced Excel skills to the construction of a polished and professional Excel
application. The book is equally useful as courseware to deliver classroom courses.

Smart Method® publications are continually evolving as we discover better ways of explaining or teaching
the concepts presented.

Feedback

At The Smart Method® we love feedback — both positive and negative. If you have any suggestions for
improvements to future versions of this book, or if you find content or typographical errors, the author
would always love to hear from you.

You can make suggestions for improvements to this book using the online form at:

https://thesmartmethod.com/contact/

Future editions of this book will always incorporate your feedback so that there are never any known errors
at time of publication.

If you have any difficulty understanding or completing a lesson, or if you feel that anything could have been
more clearly explained, we’d also love to hear from you. We’ve made hundreds of detail improvements to
our books based upon reader’s feedback and continue to chase the impossible goal of 100% perfection.

Downloading the sample files

In order to use this book, it is necessary to download sample files from the Internet. The sample files are
available from:

http://thesmartmethod.com

Type the above URL into your web browser and you'll see the link to the sample files at the top of the home
page.

Problem resolution

If you encounter any problem using any aspect of the course you can contact us using the online form at:

https://thesmartmethod.com/contact/

We'll do everything possible to quickly resolve the problem.

The Excel versions that were used to write this book

This edition was written using both the Excel 2019 perpetual license (the one-time payment version) and
Excel 365 (semi-annual version 1808, released on Jan 01 2019). You'll discover which version your computer
is running in: Lesson 2-1: Check that your Excel version is up to date.

This book is written purely for Excel 2019 and Excel 365, though readers may find some of the content is also
applicable to earlier Excel versions.

© 2018 The Smart Method® Ltd 15



Excel 2019 Construction Kit #1: Calendar and Year Planner

Typographical Conventions Used in This

Book

This guide consistently uses typographical conventions to differentiate parts of the text.

When you see this Here’s what it means

Click Line Color on the left-hand bar and then
click No line.

Italics are used to refer to text that appears in a
worksheet cell, an Excel dialog, on the Ribbon,
or elsewhere within the Excel application.
Italics may sometimes also be used for
emphasis or distinction.

Click: Home—~>Font~>Underline.

Calibri 1

BI%v i v

Font

Click on the Ribbon’s Home tab and then look
for the Font group. Click the Underline button
within this group (that’s the left-hand side of
the button, not the drop-down arrow next to
it).

Don’t worry if this doesn’t make sense yet. We
cover the Ribbon in depth in session one.

Click: Home->Font->
Underline Drop Down—>Double Underline.

Ql} 2~ A~

c

Underline

D Double Underline

Click on the Ribbon’s Home tab and then look
for the Font group. Click the drop-down arrow
next to the Underline button (that’s the right-
hand side of the button) within this group and
then choose Double Underline from the drop-
down list.

Click:

File>Options—>
Advanced->General>
Edit Custom Lists>Import

This is a more involved example.

1. Click the File tab on the Ribbon, and then
click the Options button towards the
bottom of the left-hand pane.

The Excel Options dialog appears.

2. Choose the Advanced list item in the left-
hand pane and scroll down to the General
group in the right-hand pane.

3. Click the Edit Custom Lists... button.
Yet another dialog pops up.
4.  Click the Import button.

Type: European Sales into the cell.

Whenever you are supposed to actually type
something on the keyboard it is shown in bold
faced text.

Press <Ctrl> + <Z>.

You should hold down the Ctrl key and then
press the Z key.
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When a lesson tells you to click a button, an
image of the relevant button will often be

2. AutoSum - shown either in the page margin or within the
text itself.
n Ote If you want to read through the book as

An Excel worksheet can contain
up to 16,585 columns and
1,048,476 rows.

quickly as possible, you don’t have to read
notes.

Notes usually expand a little on the
information given in the lesson text.

important

Do not click the Delete button at
this point as to do so would
erase the entire table.

Whenever something can easily go wrong, or
when the subject text is particularly important,
you will see the important sidebar.

You should always read important sidebars.

tip
Moving between tabs
using the keyboard

You can also use the
<Ctrl>+<PgUp> and
<Ctrl>+<PgDn> keyboard
shortcuts to cycle through all of
the tabs in your workbook.

Tips add to the lesson text by showing you
shortcuts or time-saving techniques relevant
to the lesson.

The bold text at the top of the tip box enables
you to establish whether the tip is appropriate
to your needs without reading all of the text.

In this example you may not be interested in
keyboard shortcuts so do not need to read
further.

anecdote

I ran an Excel course for a small
company in London a couple of
years ago...

Sometimes I add an anecdote gathered over
the years from my Excel classes or from other
areas of life.

If you simply want to learn Excel as quickly as
possible you can ignore my anecdotes.

trivia
The feature that Excel uses to
help you out with function calls

first made an appearance in
Visual Basic 5 back in 1996 ...

Sometimes I indulge myself by adding a little
piece of trivia in the context of the skill being
taught.

Just like my anecdotes you can ignore these if
you want to. They won’t help you to learn
Excel any better!

The World’s Fastest
Cars

When there is a sample file (or files) to
accompany a lesson, the file name will be
shown in a folder icon. You can download the
sample file from: http://thesmartmethod.com.

© 2018 The Smart Method® Ltd
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How to use this construction kit

Three important rules

#1 - Complete the construction kit from beginning to end

Just like a real-world construction project you need to start at the beginning and progress, one lesson at a
time, until you have completed the application.

When you have finished your project, you can re-do specific lessons by using any of the incremental sample
files to regress to any point in the construction process.

#2 If possible, complete a session in one sitting

The book is arranged into sessions and lessons (each presented upon two facing pages).

You can complete as many, or as few, lessons as you have the time and energy for each day. Many learners
have completed their construction kit by setting aside just a few minutes each day to complete a single
lesson.

If it is possible, the most effective way to learn is to lock yourself away, switch off your telephone, and
complete a full session, without interruption, except for a 15-minute break each hour. The memory process is
associative, and we've ensured that the lessons in each session are very closely coupled (contextually) with
the others. By completing the whole session in one sitting, you'll store all that information in the same part of
your memory and will find it easier to recall later.

The experience of being able to remember all the words of a song as soon as somebody has got you "started"
with the first line is an example of the memory's associative system of data storage.

#3 Rest at least every hour

In our classroom courses we have often observed a phenomenon that we call "running into a wall". This
happens when a student becomes overloaded with new information to the point that they can no longer
follow the simplest instruction. If you find this happening to you, you've studied for too long without a rest.

You should take a 15-minute break every hour (or more often if you begin to feel overwhelmed) and spend it
relaxing rather than catching up with your e-mails. Ideally you should relax by lying down and closing your
eyes. This allows your brain to use all its processing power to efficiently store and index the skills you've
learned. We've found that this hugely improves retention.

How to best use the incremental sample files

All lessons in this construction kit (apart from those that have no hands-on tasks) use a sample file that is
incrementally improved during each lesson. At the end of each lesson an interim version is always saved.
The first file you will save will be called Year Planner-1. You will then begin the following lesson with the
Year Planner-1 file and then save it (after completing all lesson steps) as Year Planner-2. By the end of the
construction kit you'll be up to Year Planner-43 (the finished application).

A complete set of sample files (including all incremental versions) are provided in the sample file set. This
provides three important benefits:

e If you have difficulty with a lesson it is useful to be able to study the completed workbook (at the
end of the lesson) by opening the finished version of the lesson's workbook.
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¢  When you have completed the book, you may want to revise some of the steps that you used to
complete it (perhaps to use the same skills in another project). The sample files allow you to work
through any single lesson in isolation, as the workbook's state at the beginning of each lesson is
always available.

¢  When teaching a class one student may corrupt their workbook by a series of errors (or by their
computer crashing). It is possible to move the class on quickly and easily to the next lesson by
instructing the student to open the next sample file in the set (instead of progressing with their own
corrupted file or copying a file from another student).

© 2018 The Smart Method® Ltd
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Session One: Methodology
& Functional Specification

Give me six hours to chop down a tree and I will spend the first four
sharpening the axe.

Abraham Lincoln, 16™ President of the United States (1809-1865)

Imagine you are building a house. You wouldn’t just race into a field and
start digging foundations. You’d begin by employing an architect to
carefully design every aspect of the finished house.

You wouldn’t begin building the house until everything had been
carefully designed and documented. In other words, you’d have to know
exactly what you were building before you started building it.

You’'d be amazed to know that in the world of business, most real-world
software projects are not planned quite so well. In fact, some are not
designed and documented at all. It is often the case that managers don’t
understand the need for a design phase and expect developers to begin
construction on the first day of a project.

Methodology

This construction kit uses a high-quality application development
methodology sometimes called the waterfall model. If you use this
approach, you'll develop higher quality solutions faster — no matter how
small the project is.

The basis of the waterfall model was first defined in 1970 by a paper
authored by Winston W. Royce (a computer scientist at Lockheed
working on the space program).

Winston had spent nine years developing software for spacecraft mission
planning, commanding and post-flight analysis. His 1970 paper distilled
his vast experience into the observation that software development
consisted of two steps: Analysis and Coding. More simply put, you have
to figure out what you need to do before you actually do it.

Winston observed, however, that in larger systems, any project that
included only these two steps was “doomed to failure”. In this session
you'll learn how to use Winston’s waterfall model. Even though this is a
simple application, you'll still use the waterfall model to design it.

The Functional Specification

The waterfall model requires that every project should begin with a
Functional Specification.

It may seem like overkill to have a functional specification for such a
small project, but as you progress through the construction kit you'll
appreciate the usefulness of this approach. You'll also realize how much
longer everything would have taken if you hadn’t specified what you
needed to do before starting.

© 2018 The Smart Method® Ltd
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anecdote

It is often the case that non-
technical project managers
expect programmers to begin
coding on the first day of a new
software project. They find it
hard to understand why the
first months of a large project
need to be spent documenting
and designing.

I have my own acronym for
managers that ask this
question: WIMP.

It stands for “Why Isn’t Mike
Programming”.

Lesson 1-1: Understand the
Waterfall Model

How the waterfall methodology is used in this
construction kit

During my own career developing large software systems (for corporate
clients in different business areas) I have discovered many different
names given to the steps originally identified by Winston Royce. Here are
my preferred names for the steps you need to successfully complete a
project along, with their many aliases:

Step One: Functional Specification

Other names: Requirements Specification, Requirements Analysis,
Requirements Definition, Software Requirements, Specification, Spec,
Analysis, Project Analysis Document, Problem Statement, Conceptual
Design, Goal Centered Design, Logical Design.

What it really means: What the application needs to do, but not what it
will look like or how it will do it.

Your users will need to sign-off on the Functional Specification before you
proceed to the User Interface.

Step Two: User Interface

Other names: Prototype, User Interface Design, User Interface
Specification.

What it really means: What the application looks like and how it will
deliver the requirements detailed in the Functional Specification.

Later, in: Session Two: Create the User Interface, you’ll design a user
interface that will show how all of the features described in the functional
specification will be delivered.

You'll deliver the user interface as a non-functioning, annotated Excel
workbook. This can then be shared amongst your users to make sure they
are happy with the final appearance and how the application will work
before you spend time making everything work.

Step Three: Construction

Other names: Coding, Implementation, Coding & Debugging,
Programming.

What it really means: Making everything in the user interface work as
specified.

In the construction phase you’ll go on to make the features that were
specified in the functional specification work using the user interface you
have designed.

22
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Step Four: Testing

Other names: System Testing, Integration Testing, Acceptance Testing.

What it really means: Working through the Functional Specification and
making sure that the finished application reliably and correctly provides
all of the functionality that was specified there.

How the four phases of the waterfall model work
together

Functional
Specification

User Interface ‘D

The above diagram shows how the Functional Specification and User
Interface fit into the overall development process. You can see that each
process overlaps. This is designed to indicate some degree of interaction
between each step and the preceding step. In other words, users may see

: the User Interface and then realize that it doesn’t cater for a requirement
government published a ) . . o
document titled: Defense that should properly have been included in the Functional Specification. At
Systems Software Development this stage, the uncaptured requirement can be added to the Functional
(DOD-STD-2167A). Specification and incorporated into the User Interface.

note

In 1985 the United States

This document broadly

d ibes the Waterfall Method . .
as the preferred standard for  YOU should only ever re-iterate to the previous

software development. ste P
The document defined six o
phases (an elaboration of the The waterfall model insists that there should be no overlap other than

four described in this lesson): with the preceding step.

e  Preliminary Design This means that once the functional specification and user interface have
been agreed, development can only proceed efficiently if no further

e  Detailed Desi
&n functionality is added to the current version.

e Codin

é Any late requests for enhancements should form the subject of a new
functional specification for the second release and you should not try to
e Integration incorporate them into the current version. This is an absolutely essential
discipline for efficient software development.

e  Unit Testing

e Testing

Vil s maee alheut: ik You can see now why Winston’s methodology has been called the

testing and integration testing waterfall model. Water only flows one way in a waterfall, just as the project
in: Lesson 7-4: Remove test data flows from left to right in the diagram above (but never from right to

and finalize the year planner. left).
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Lesson 1-2: Understand the
structure of a functional
specification

A good functional specification completely describes an application
without considering what the user interface will look like or how the
functionality will be implemented.

The functional specification should describe all of the things that the
application needs to do.

Make sure that the functional specification
describes what the application does and not
how it will do it

I've organized many meetings with business experts to draw up a
functional specification for a new software solution. Some have been for
very large systems with functional specifications stretching to over 200

pages.
At the beginning of the meeting I always emphasize that users are not
allowed to talk about the user interface when describing functionality. Of

course, they always do, and I have to work hard to steer them back to
functionality.

For example, a user will say something like:

“We need a drop-down list showing different countries and when you click on a
country a box will pop up showing year-to-date sales for the current year”.

The user needs to be brought back onto track to state the actual
requirement as:

“It must be possible to quickly view year-to-date sales for any country”.

Later, when the user interface is designed, the users can see how it is
proposed to deliver the functionality defined in the functional
specification. This may be very different from the way in which the user
originally visualized it.

Staying focused in this way will allow you to capture the requirements of
the business far more precisely.

The three main sections of a functional
specification

Mission statement

“There are no big problems, there are just a lot of little problems.”

Henry Ford, founder of the Ford Motor Company (1863-1947)
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Important

Always organize a
sign-off meeting for
the functional
specification

I'have discovered that if you
simply e-mail a functional
specification to a client for
review it is rare for anybody to
invest the time needed to read
it.

The functional specification is
hugely important as it defines
success. Your project will
demonstrably be a success if it
delivers all the functionality
defined in the functional
specification.

If you don’t make sure that the
functional specification is
accurate you are setting
yourself up for failure when
you deliver the finished
application.

I'have found it best to organize
a meeting of stakeholders
including business experts and
the actual end-users of the
application.

Read out each requirement at
the meeting and invite
questions. You’d be amazed
how many new requirements
you will capture by doing this.

I've often had to organize a
second meeting to review
version 2 of the functional
specification as it had to be
completely re-written after the
first sign-off meeting.

The best way to start a functional specification is with a mission
statement. You need to turn Henry Ford’s words upside down and
appreciate that the project will solve lots of little problems but can also be
described in a more abstract way as one big problem.

Ideally your mission statement will consist of a single sentence, but it
could also be extended to two or three sentences.

You'll see the mission statement for this construction kit later, in: Lesson
1-3: The Functional Specification.

Primary business objectives

Having defined the mission statement, the primary business objectives
now flesh out the requirement in a little more detail.

There will normally be less than ten primary business objectives even in a
large system.

You'll see the primary business objectives for this construction kit later,
in: Lesson 1-3: The Functional Specification.

Requirements

Having defined the mission statement and the primary business objectives,
the requirements now express in detail the precise functionality that the
system needs to deliver.

You'll see the requirements for this construction kit later, in: Lesson 1-3:
The Functional Specification.

© 2018 The Smart Method® Ltd
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Lesson 1-3: The Functional Specification

Here is the functional specification for the application you are about to create.

When the application is complete it will be possible to test it against this functional specification to confirm
that all of the features specified have been delivered.

Mission Statement

To create a year planner that can be easily be populated with different date-related events.

Primary Business Objectives

1. Provide a calendar that will show an entire month of dates and events.

Allow the user to quickly select any year or month.

Allow the user to select Sunday or Monday as the first day of the week.

Show the phase of the moon for each date.

Allow one fixed event (such as Christmas Day or New Year’s Day) to be displayed for each date.
Display custom events defined by the user for each date (such as appointments or birthdays).

Allow both fixed and custom events to recur each year if required.

® N o G B LD

Allow users to customize the calendar by enabling or disabling event types that they may have no use
for.

9. Ensure that the finished calendar looks professional when printed.

Requirements

1. Supported date range

The calendar needs to support, as a minimum, all dates up to 100 years in the past and up to 100 years in
the future. For the purposes of this specification this will mean the date range: 1st January 1918 to 1st
January 2118.

2. Information to be shown for each date

2.1. The calendar will always show 37 days, starting with the Monday or Sunday on or before the 1st of
the month that is being displayed.

2.2. Moon Phase

For every date in the supported date range, it should be clearly indicated which phase of the moon
is active. Eight different phases of the moon should be displayed:

e New Moon

e Waxing Crescent
e First Quarter

e Waxing Gibbous
e Full Moon
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¢ Waning Gibbous
e Last Quarter
e Waning Crescent
3. Fixed events
The following fixed events will be automatically calculated and included (for every year):
e New Year's Day
e Martin Luther King Day
e Presidents' Day
e Easter Sunday
e Memorial Day
¢ Independence Day
e Labor Day
e Columbus Day
e Veteran's Day
¢ Thanksgiving Day
e Christmas Day
4. Custom events

4.1. It must be possible for a user to quickly define several custom events for each day (such as a
birthday, holiday or appointment).

4.2. Events must be restricted to the visible space available for display for each calendar day without
scrolling.

4.3. Tt must be possible to define custom events that are up to 32 characters (in total) long for each day.
5. Recurring events

It must be possible for a user to define each custom event as recurring or non-recurring. A recurring
event is defined as an event that will occur on the same date of every year in the supported date range.

6. Calendar Settings
6.1. Customization of calendar display
It must be possible to show or hide Moon Phases, Fixed Events and Custom Events.
6.2. First day of the week
It must be possible to define either Sunday or Monday as the first day of the week.
7. Usability
7.1. The user must not need any Excel skills or training
7.2. The year planner must be intuitive and easy to use for untrained users.
7.3. On-screen help must be provided whenever the purpose of any on-screen item is not obvious.
8. Compact design

8.1. The main features of the application should be designed so that users do not have to scroll their
screens when using a standard 22-inch monitor (providing a resolution of 1680X1050).
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8.2. The calendar should appear professional and legible when printed upon one sheet of Letter-Sized
or A4 paper (in landscape orientation).

9. Security
9.1. It must not be possible for a user to break any of the functionality of the application in normal use.

9.2. The implementation must not make use of any VBA or macro code.
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Good looks only take you so far.

Angie Everhart, American Actress (1969-)

When the functional specification has been completed and (most
importantly) signed off by users, the next step will be to design the user
interface.

In this lesson you’ll design the visual appearance of the year planner
application. You can then submit the workbook to users for approval
before you move on to make each feature work.

Sometimes users will see the user interface and then identify new
requirements that were missed when the functional specification was
agreed.

In: Lesson 1-1: Understand the Waterfall Model, you learned that it is
permissible to re-visit the functional specification if new requirements are
identified as a result of making a non-functioning user interface available
to users.

Session Objectives

By the end of this session you will have:
Checked that your Excel version is up to date
Designed the user interface

Applied background colors

Applied borders

Resized rows and columns

Added test values

Applied text formatting

Merged cells

Added moon phase icons

Added a company logo

Added controls

Created a table for non-recurring custom events

Created a table for recurring custom events

Packaged the user interface for review by users

© 2018 The Smart Method® Ltd
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important
Update Channels

Update channels determine
when users will receive the
latest Excel version.

Excel 2019 perpetual users

If you have a perpetual license
(the pay-once version of Excel
2019) you will not receive any
feature updates, so you do not
have an update channel.

Excel 365 home users

If you have a subscription
version of Excel 2019 (this is
referred to as Excel 365 in this
book) that is targeted at home
users, you are required to
receive monthly updates.

This is called the Monthly
Channel.

You will potentially receive
new or improved features
every month.

Excel 365 business users

New features added in the
Monthly Channel may have
bugs, as they will not yet have
been extensively tested by real-
world use.

If you have an Excel 365
version that is targeted at
business users (usually called
Excel Pro Plus), you will (by
default) use the Semi-annual
Update Channel.

The Semi-annual Channel allows
new features to be thoroughly
tested before use. It is possible
(though difficult) for Excel Pro-
Plus users to change their
update channel to the Monthly
Channel.

The Semi-annual Channel only
updates Excel twice each year
(in January and July).

This book was written using
Excel Semi-Annual Version 1808.
This version was released to
Monthly Channel users on Jul 24,
2018 and was released to Semi-
Annual channel users on Jan 01
2019.

Lesson 2-1: Check that your
Excel version is up to date

Automatic Updates

Normally Excel will look after updates without you having to do
anything. By default, automatic updates are enabled. This means that
updates are downloaded from the Internet and installed automatically.

It is possible that automatic updates have been switched off on your
computer. In this case there is a danger that you may have an old, buggy,
unsupported and out of date version of Excel installed.

This lesson will show you how to make sure that you are using the latest
(most complete, and most reliable) version of Excel.

1 Start Excel and open a new blank workbook (if you have not
already done this).

2 Make sure that automatic updates are enabled.

1. Click the File button “ at the top-left of the screen.

This takes you to Backstage View. Backstage View allows you to
complete an enormous range of common tasks from a single
window.

2. Click: Account m in the left-hand list.

Your account details are displayed on screen. Notice the Office
Updates button displayed in the right-hand pane.

If all is well, and automatic updates are switched on, you will
see a button similar to this:

& Office Updates

b C5 Updates are automatically downloaded and installed.
Update
Options ~

If automatic updates have been switched off, you will see a
similar button to this.

i Office Updates
i = This product will not be updated.
Update

Options ~

In this case you will need to switch automatic updates on (see
next step).

3 Switch on automatic updates if necessary.
Click: Update Options->Enable Updates.
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note

Version number and
Build

A new Excel version is usually
released to the monthly update
channel every month.

Each new version may add new
features to Excel 365.

If bugs or security issues are
found in a new version,
Microsoft will fix them and
publish a new build of the same
version.

It is quite normal for there to be
several new builds of each new
version during the month that it
is released.

Office Updates
1] 5

This product will not be updated.
Update
Options =

T Enable updates
Autorj:?tically receive the latest updates
for sectity, performance, and reliability.

4 If there are updates waiting to install, apply them.

Sometimes Excel will download updates but will not install them
automatically.

In this case you will see an update button similar to the following;:

4 Office Updates
L3 Updates for this product are ready to install.
pdate

Options ~

If you see this type of button you should apply the update.
Click: Update Options=> Apply Updates.

You may be asked to confirm that you want to apply the update,
and to close any open programs to apply the update.

5 Notice your version number and update channel.

Product A

Product Information

] Office

Product Activated
Microsoft Office Home and Student 2019

9 About Excel

About Product ID, and Copyright
Excel information.

Click-to-Run)

Learn more about Excel, Support,

Version 1808 (Build 11001.20074

Product B Product C
Product Information Product Information
Subscription Product Subscription Product
Microsoft Office 365 ProPlus Microsoft Office 365
0 About Excel @ About Excel
Learn more about Excel, Support, Learn more about Excel, Support,
About Product ID, and Copyright About Product ID, and Copyright
Excel information. Excel information.
Version 1808 (Build 10730.20155 Click- Version 1807 (Build 10325.20082
to-Run) Click-to-Run)
Semi-annual Channel (Targeted) Monthly Channel

note

Perpetual license
versions have
different features

Perpetual license holders still
receive monthly updates, but
these only include security
updates and bug fixes (not new
features).

A perpetual license holder
running Version 1808 will thus
see different features than a
subscription license holder
running the same Excel version.

You will see a product information section displayed. If you see
the number 365 or the words Subscription Product, you will know
that you are using the subscription version of Excel 2019 (this is the
case for products B and C above). Otherwise you are using the
perpetual license version (this is the case for product A above). In
this book, the perpetual license version will be referred to as Excel
2019 and the subscription version as Excel 365.

Notice also the update channel and version numbers (see sidebars).

6 Click the Back button to leave Backstage View and
return to the worksheet.

7 Click the Close button in the top-right corner of the Excel
screen to close Excel.

© 2018 The Smart Method® Ltd
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Lesson 2-2: Design the user
interface

MON TUE WED THU FRI SAT SUN
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3 [0 20N D 10 > 11 > 12 P> 13 ® 14 »
Feed Cats Jimmy's Birthday
15 ® 16 ®» 17 ® 18 ® 19 ® 20 @ 21 q
22 e 23 e 2 C 25 C 2 ¢ 27 © 28 O
29 O a0 C a1 0] o} O O 0
o} o]
First Day of Week Monday

After reviewing the Functional Specification described in: Lesson 1-3: The
Functional Specification, it is possible to identify several design-related
constraints that must be satisfied. They are:

1. Show an entire month of dates and events.
2. Allow the user to quickly select any year or month.

3. Allow the user to select Sunday or Monday as the first day of the
week.

4. Show the phase of the moon for each date.

5. Allow one fixed event (such as Christmas Day or New Year’s Day) to
be displayed for each date.

6. Display custom events defined by the user for each date (such as
appointments or birthdays). It must be possible to display custom
events that are up to 32 characters (in total) long for each day without
scrolling.

7. It must be possible to show or hide Moon Phases, Fixed Events and
Custom Events.

8. Ensure that the finished calendar looks professional when printed
upon one sheet of Letter-Sized or A4 paper (in landscape
orientation).

9. The calendar must show 37 days, starting with the Monday or
Sunday on or before the 1st of the month that is being displayed.
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It is important to appreciate that graphic design and technical
implementation are different skills. For this reason, you might decide to
use a graphic artist to create the final design.

For the purposes of this lesson, imagine that your designer has submitted
the design (shown at the start of this lesson) for approval. You have
checked it against the design constraints and decided that it is capable of
delivering the functionality required.

You now need to re-create the design within Excel.

The calendar presents a complex user interface that will require
information to appear in many different places. To make this possible,
each area where a different piece of information will appear needs to be a
distinct cell.

For example, above each day in the calendar you need to show the day
number and an icon indicating the phase of the moon. In order to do this
in Excel, you will need one cell for the day number and another cell for
the moon phase.

A designer will usually create a layout using guides (that are normally
hidden when the design is printed out). In this case, the designer has
provided you with a copy of the design with visible guides (used by the
designer to align each item). The guides resemble the rows and columns
that appear upon an Excel worksheet. Here is the user interface design
with guides:

MON TUE WED THU FRI SAT SUN
1 C| 2 C| s O] ¢ Ol s Ol s Q7 a
thesmartmethod.com Dentist's
Appointment
8 Q| s | 10 Q| 11 Q| 12 | 13 ®| 12 ®
Feed Cats Jimmy's
Birthday
15 ®| 15 ®| 17 ®| 13 ®| 15 ® 0 o 2 [ ]
22 @ 23 o 24 ©| 25 ©| 26 ©| 27 © 28 C
29 C| so C| 51 o o o ®) 0
9] o]
First Day of Week Monday
Show Moon Phases
Show Fixed Events
Show Custom Events

As you can see, the design will require 21 columns and 26 rows.

You'll begin by applying background colors to define each part of the
calendar, then you'll resize the rows and columns, add borders, merge
cells as necessary and finally populate cells with test values.

© 2018 The Smart Method® Ltd
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note
The RGB color model

In the 18" century scientists
discovered that the human eye
had three types of color-sensing
cells (called cone cells).

Interestingly, birds and fish
have four cone cells (meaning
that they can see more colors
than humans) and dogs only
have two.

The human eye can determine
around ten million different
colors.

Most computers use an RGB
model called True Color.

True Color mixes 256 different
shades of Red, Green and Blue
together to define a color. This
means that a computer can
display 16 million different
colors (more than the human
eye can see).

Many corporations have their
own “corporate colors” that
enable customers to quickly
recognize their brand.

In this lesson you define a color
that we’ll refer to as Smart
Method Indigo. This is one of the
colors used in the Smart
Method logo.

Smart Method Indigo can be
created by adding 36 parts of
Red to 34 parts of Green and 99
parts of Blue.

- A ===

il
i

|

Theme Colors slignment

HE EN m

Blue, Accent 3

oARNRNEEEE

Standard Colors
N TIIrl
Na Fill

v More Colors..
[

Lesson 2-3: Apply background
colors

You know from the design concept which colors that will be used in this
project. One of the colors is The Smart Method’s corporate Indigo
background (used on their web site and some book covers). This color
does not exist in any of Excel’s built-in color sets, so it is best practice to
define it as a custom color by specifying the RGB (Red, Green and Blue)
components.

1 Open Excel and create a new blank workbook.

2 Select all cells and apply a gray background color.
1. Select all cells, either by clicking the Select All button |:| (or
by using the <Ctrl>+<A> keyboard shortcut.
2. Click: Home->Font->Fill Color.

3. Apply the Light Gray, Background 2 fill color (the 34 color from
the left on the top row of colors).

Theme Colors

[}I |

|
I Light Gray, Background 2
T

Standard Colors

] EEEEN
Me Fill

ulig

vy More Colors...

3 Select cells B2:T25 and apply the No Fill background color.
These are the cells that will contain the calendar.

4 Select cells F3:S3 and apply the Orange-Accent 2
background color (the orange color on the top row).

These are the cells that will contain the names of each day of the
week.

) Select cells C3:D24 and apply the Blue-Accent 5 background
color (the second color from the right on the top row).

Excel’s default color set doesn’t include the indigo color used in
the design specification. The nearest is Blue-Accent 5 but that isn't
an exact match.

You could define the correct color using the More Colors option, but
this would prevent the colors from automatically changing if the
user changed the theme.

To enable themes to work correctly, you'll select the Accent 5 color
and change Accent 5 in this workbook’s Color Set to the indigo color
that you need.

6 Customize the workbook’s Color Set so that the Accent 5
color matches the indigo color in the specification.
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Create New Theme Colors

Theme colars

Text/Background - Dark 1

Text/Background - Light 1

. -
[ |-

Sam

Text/Background -Dark 2 | [l ~

Text/Background - Light2 |[ | =

Accent 1 -

Accent 2 o -

Accent 3 o -

Accent 4 = -

Accent 5 -

Accent & Theme Colors

) H H HENE

Hyperlink

Followed Hyperlink

Mame: |Custom 1

Reset

Standard Colors
[ § | O

ar Mq\@ Colors...
Ly’

1. Click: Page Layout->Themes->Colors->Customize Colors.
2. Click: Accent 5>More Colors.
3. In the Red, Green and Blue boxes, enter the values 36, 34 and 99.

Colors ? *x

Standard  Custom

Colors: Cancel

Color model: |RGE

Red: 36 5

Green: 34 |=

Elue: 9g.| =

Current

4. C(Click: OK.

5. In the Name box, enter: Year Planner Color Set
6. Click: Save.
Cells C3:D24 change to the correct color.

You can now see a very basic outline of the calendar. In the next
lesson, you’ll add borders according to the design concept.

You'll notice that you didn’t add shading for weekends. This is
because the calendar needs to be able to work with either Monday
or Sunday as the start of the week, meaning that the shaded
weekend area will move according to the settings.

You'll apply the weekend shading using Conditional Formatting
later, in: Lesson 3-10: Add conditional formatting for weekends.

J K L M N (o] P Q R S T u

Save the workbook as Year Planner-1.

© 2018 The Smart Method® Ltd
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| Farmula Bar
&Gridlines +| Headings

Show

- D- A~
Borders
i Bottom Border

Top Border

Left Border

Right Border
#+ No Border
All Borders

Qutside Borders

Thick Qutside Borders

il
L]

Lesson 2-4: Apply borders

1 Open Year Planner-1 (if it isn’t already open).
2  Switch off gridlines.

Click: View—>Show—>Gridlines.

Switching off the gridlines makes it easier to see the borders that

you are going to apply.

3 Apply a solid black border around cells B2:T25.

1. Select cells B2:T25.

2. Click: Home—>Font2>Borders—> Outside Borders.

4 Apply a gray border around cells F4:524.

1. Select cells F4:524.

2. Click: Home—>Font>Borders->Line Color and select the White,
Background 1, Darker 25% color (the 4™ from the top on the left-
most column).

[# Line Calor * B Automatic
Line Style * | Theme Colors
B More Borders... n mm R
J I EEEER I | |
r'.";"hitr:_. Background 1, Darker 25%
(1] EEEEE |
vy More Colors..,
The cursor changes into a pencil , indicating that you are in
border-drawing mode.
3. Click and drag to draw a gray border around cells F4:524.
5 Draw the borders for the calendar cells.

Click and drag to draw the remaining borders for the calendar
cells, so that the workbook looks like this:

F G H | J K L M N o P Q R S T

Year Planner-1

6

N

Press <Escape> to exit border-drawing mode.

Apply a dark blue border to the bottom of cells F3:S3.
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Bl Automatic [

Theme Colors

' B mEEm

gy 2Vied by dlickin
t %

Indigo, Accent 5

[
I
-Illllllil

Standard Colors

1. Select cells F3:S3.

2. Right click the selected cells and click Format Cells from the

shortcut menu.

3. Click the Border tab.

4. Select the thickest solid border style and the new Indigo, Accent
5 custom color that you created in: Lesson 2-3: Apply background

colors.

5. Click the button indicating a bottom border and click OK.

Format Cells

Mumber  Alignment Font Baorder Fill

Protection
Presets
MNone  Qutline  [nside
Border
Text

N EEEEN

vav More Colors... o =
With the borders in place, the framework of the calendar is now
much more obvious.

A B T D E F G H J K L M N o P Q

1

2

3

4

5

6

7

8

8

In the next lesson you'll resize the rows and columns so that they
are the same size as those shown in the design concept.

Save the workbook as Year Planner-2.

© 2018 The Smart Method® Ltd
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Lesson 2-5: Resize rows and
columns

1 Open Year Planner-2 (if it isn’t already open).
2 Resize the columns according to the specification.
1. SelectcolumnsB,E, G, I,K,M, O, Q,Sand T.

To do this, hold down the <Ctrl> key on your keyboard and
click each column heading.

2. Click and drag the edge of any of the selected column
headings to resize all of the selected columns to be 20 pixels

wide.
T1 - 5
Width: 2.14 (20 pixels)
A | B| C D F+ F |G| H ]
1 ]
2
3. Select columns F, H, J, L, N, P and R and resize them to be 93
pixels wide.
4. Resize column C to be 117 pixels wide.
5. Resize column D to be 48 pixels wide.
6. Resize columns A and U to be 17 pixels wide.
The columns are now all the correct size.
A c D £ F G H i ) K L M N o P a R STV

0~ o R W R

3 Resize the rows according to the specification.

1. Resize row 3 to be 39 pixels high.
Year Planner-2 |
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You can resize rows in almost the same way as you resized
columns. Click and drag the edge of row 3 to resize the row to
39 pixels.

2. Resize rows 6,9, 12, 15 and 18 to be 68 pixels high.

Resizing multiple rows is the same as resizing multiple
columns. Hold down the <Ctrl> key and then click on each
row number to select them. You can then resize them all at the
same size by resizing any of the selected rows.

3. Resizerows1,5,8,11, 14,17, 20, 21, 22, 23, 24 and 26 to be 17
pixels high.

The calendar’s appearance now perfectly matches the design
specification. In the next lesson, you'll add some test values to the
calendar’s cells to match the design brief.

4

Save the workbook as Year Planner-3.

© 2018 The Smart Method® Ltd
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Lesson 2-6: Add test values

Before making the calendar functional, you're going to add some test
values to the cells. This will enable you to make sure that the values
appear in the right places and confirm that the formatting is correct.

1
2

tip
Entering the dates
quickly

Remember that you can press
the <Tab> key to quickly enter
data into a cell and move to the
cell to the right.

This makes entering the dates
easier, as you don’t have to
move your hands off the
keyboard to select the next cell.

When entering the numbers in
step 3, you'll need to press the
<Tab> key twice after entering
each number because the
numbers are two cells apart.

Year Planner-3 4

Open Year Planner-3 (if it isn’t already open).

Add the week days to row 3.

1. Click in cell F3 and type the text: MON

2. Select cells F3:G3 and then AutoFill across to cell S3.

To AutoFill across, click and drag the fill handle on the bottom-
right corner of the selected cells.

MON l

Because you've selected both the cell containing MON and the
blank cell next to it, Excel is able to figure out that you want to
leave a blank cell between each day of the week.

Don’t worry about the formatting of the text for now. You'll
change that later, in: Lesson 2-7: Apply text formatting.

Enter the numbers for each date.

For testing purposes, you're going to enter the dates for the month
of January 2016.

1. Enter the numbers 28, 29, 30 and 31 in cells F4, H4, J4 and L4.

As shown in the design concept, the calendar will always show
37 days, showing the dates from the next or previous months
wherever they overlap.

These numbers represent the 28t to 315t of December 2015 to
match the dates shown in the design.

2. Enter the numbers 1, 2, and 3 in cells N4, P4 and R4.
These represent the 1+, 2nd and 3¢ of January 2016.
3. In the same columns on row 7, enter the numbers 4-10.

You can use AutoFill to speed this up in the same way as you
did with the days of the week.

In the same columns on row 10, enter the numbers 11-17.
In the same columns on row 13, enter the numbers 18-24.
In the same columns on row 16, enter the numbers 25-31.

Enter the numbers 1 and 2 in cells F19 and H19.

N o

These represent the 1+t and 27 of February 2016.

All of the numbers are now in place. You'll notice that they’re not
aligned or formatted correctly. You'll change that later, in: Lesson
2-7: Apply text formatting.

Enter some fixed events.
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note

If the text is hard to
read

The text that you enter in steps
6 and 7 might be hard to read,
as it will be black text on a very
dark indigo background.

If this is a problem for you,
temporarily change the
background color of the cells to
a lighter color. You'll reformat
the text to make it easier to read
on a dark background in the
next lesson, so you should
change the color back at that
point.

1. Enter New Year’s Day in cell N5.
Cell N5 is below the cell indicating the 1%t of January 2016.
2. Enter Martin Luther King Day in cell F14.
Cell F14 is below the cell indicating the 18t of January 2016.
5 Enter some custom events.
1. Type: Dentist's Appointment in cell P6.
2. Type: Feed Cats in cell R.
3. Type: Jimmy’s Birthday in cell H12.
6 Enter the year and month in cell C11.
Enter Jan 2016 in cell C11.

This will be the wrong color and size and won’t be formatted
correctly, but for now entering the value is all that is important.

7 Enter the headings for the calendar settings.
1. Type: First Day of Week in cell C20.
2. Type: Monday in cell D20.
3. Type: Show Moon Phases in cell C21.
4. Type: Show Fixed Events in cell C22.
5. Type: Show Custom Events in cell C23.

The calendar is now populated with test data. As you can see, a lot more
formatting is needed to match the design concept. You'll apply that
formatting in the next lesson. (In the grab below the color of the left-hand
bar has been lightened so that you can see the text entered).

A B © E F G H I J K L M N [} P Q R S|T|\Y
1
2
3 MON TUE 'WED THU FRI SAT SUN
4 28 29 30 31 1 2 3
5 New Year's Day
6 Dentist's Appointment
7 4 5 6 7 8 9 10
8
9 Feed Cats
10 11 12 13 14 15 16 17
1 Jan-16
12 Jimmy's Birthday
13 18 19 20 21 22 23 24
14 Martin Luther King Day
15
16 25 26 27 28 29 30 31
17
18
19 1 2
20 First Day of Week Monday
21 Show Moon Phases
22 Show Fixed Events
23 Show Custom Events
24
25
26

8  Save the workbook as Year Planner-4.

© 2018 The Smart Method® Ltd
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==_ #- %‘Wrap Text
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Align your content to the left.

| 1 L E

E-’_::[ = Merge & Center ~  ©2 ~ 9

Alignment F} M

Increase Indent

Move your content farther away

| frem the cell border.

Calibri -3 - A A
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Fant P
Calibri -8 - AN
B I U-
Font I

Year Planner-4 |

Lesson 2-7: Apply text
formatting

1
2

Open Year Planner-4 (if it isn’t already open).
Align the dates to the left.

If you look at the design concept, you'll see that the date numbers
are supposed to be left-aligned. They are currently right-aligned
because that is Excel’s default for numeric values.

1. Select cells F3:524.
2. Click: Home=> Alignment-> Align Left.

All of the selected cells are now left aligned.
Apply a left indent to cells F3:S24.

The design concept shows that all of the values in the calendar are
slightly indented from the left. You can apply this to your calendar
using Excel’s Alignment features.

1. Select cells F3:524 (if they’re not still selected).

2. Click: Home-> Alignment->Increase Indent.

The week days, events and date numbers are all slightly indented.
Set the font size of cells F4:S24 to 10 points.

Set the font style for the week day names.

1. Select cells F3:53.

2. Set the font size to 13 points (you will have to type this into the
font size box).

3. Make the text bold.

4. Set the font color to Indigo, Accent 5 (the same as the blue
sidebar).

Set the font style for fixed events.

1. Select cells F5:S5, F8:S8, F11:511, F14:514, F17:517 and F20:120
(all of the cells that will contain fixed events).

2. Set the font color to Green, Accent 6.

3. Click: Home-> Alignment->Decrease Indent to remove the
indent from fixed events.

4. Set the font size to 8 points.

Martin Luther King Day is the widest fixed event that is
specified in the Functional Specification. A font size of 8 points
(in the Calibri font) is thus the largest font size that can be
used.

Set the font style for custom events.

1. Select cells F6:56, F9:59, F12:512, F15:515, F18:518 and F21:121
(all of the cells that will contain custom events).
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- ¢ Wrap Text

Alignment

== H Merge & Center -

[

8

Calibri 24 -

B I U -

Font

A

S aa-

-

A

F]

B~ ¢ Wrap Text

€= 3=

Merge & Center ~

Alignment

ul

Set
1.

2
3.
4
5

6.
The

Click: Home-> Alignment->Top Align to display all of the
custom events at the top of their cells instead of at the bottom.

Click: Home-> Alignment->Wrap Text to prevent custom
events from overflowing their cells.

the font style for the year and month.
Select cell C11.

Set the font size to 24 points.

Make the text bold.

Set the font color to Gold, Accent 4.

Set the vertical alignment to Middle Align and the horizontal
alignment to Center.

Click: Wrap Text to enable text wrapping.
text is too big to fit in cell C11, so it will be cut off in the

display. You'll fix this later, in: Lesson 2-8: Merge cells, by merging

cell

C11 with other nearby cells.

9 Set the font style for the settings.
1. Select cells C20:D23 (the cells where the calendar settings are
displayed).
Calibori 2. Set the font size to 8 points.
B u- 3. Make the text bold.
e = 4. Set the font color to White.
A B C D E F H | J K L M N (o] P Q R S T U
;
2
3 MON TUE WED THU FRI SAT SUN
4 28 29 30 31 1 2 3
5,
Dentist's
Appointment
6
7 4 5 6 7 8 9 10
8
Feed Cats
9
10 11 12 13 14 15 16 17
11 Ian-16
Jimmy's
Birthday

18

25

First Day of Week

Monday
Show Moon Phases
Show Fixed Events

Show Custom Events

19

26

20 21 22 23 24

27 28 29 30 31

10

Save the workbook as Year Planner-5.
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tip

Speeding up merging

cells

The Merge Cells command is a
little awkward to access, since
you have to open the Merge &
Center dropdown menu every
time you want to use it.

You can make it quicker to
access by adding it to your

Quick Access Toolbar. To do this,

right-click on the Merge Cells
command and click Add to
Quick Access Toolbar from the
shortcut menu.

You can now merge cells with
one click instead of two.

Adding a command to your
Quick Access Toolbar also
automatically creates a
keyboard shortcut. The first
item on your Quick Access
Toolbar can be accessed using
<Alt>+<1>, the second with
<Alt>+<2>, and so on. This
allows you to quickly merge
and center cells without

needing to use the mouse at all.

Format Cells

MNumber  Alignment Font Border

Category:

Sample
Jan2016

General
Mumber
Currency

Accounting
Date
Time

Type:
mmm

Fill

Percentage ##0,0E+0
Fraction #7
Scientific I
Text dd/mm,fyyyy
Special dd-mmm-yy
EECT— | | idnnn

Year Planner-5

Lesson 2-8: Merge cells

All of the formatting is now correct, but some of the cells need to be
merged. The text indicating the year and month needs a lot of screen
space, so you'll merge several cells into one larger cell to give it more

room.

There are also several other cells that should be merged to increase the
amount of information that can be displayed in each part of the calendar.

1
2

Open Year Planner-5 (if it isn’'t already open).
Switch gridlines on.

Click: View—>Show->Gridlines to display the gridlines (if they’re
not already visible).

The gridlines will make it easier to see where cells have been
merged.

Merge & Center cells C11:D15.
1. Select cells C11:D15.
2. Click: Home=> Alignment->Merge & Center.

The year and month are no longer cut off, as they now have space
to be fully displayed.

Set the format for the year and month.

Now that the year and month are fully visible, you can see that
they don’t quite match the design concept. They should be
displayed in the format Jan 2016 instead of Jan-16.

1. Right-click cell C11 and click Format Cells from the shortcut
menu.

2. Click the Number tab (if it isn’t already selected) and click
Custom from the left-hand list.

3. In the Type box, enter: mmm
4. Still in the Type box, press <Ctrl>+<]J>.

This is a (very little known) way of entering a line break within
a custom format.

5. Finish the custom format with: yyyy

You won’t be able to see this text as you type it, but you will
see the year appear in the Sample box above.

6. Click: OK.

The year and month are now displayed correctly. If the line break
between the year and month isn’t visible, it's because you forgot to
switch on Wrap Text for cell C11 in the previous lesson.

Merge the cells for custom events.

If you look at the cells that contain custom events, you'll notice that
there is an extra cell to the right of each event.

You can see that the fixed events, such as Martin Luther King Day
aren’t bothered by this because they’re able to overflow into the
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cell to the right. However, Wrap Text has been enabled for the cells

containing custom events, preventing them from overflowing into
the next cell.

In order to give custom events as much space as possible, you need

to merge each custom event cell with the cell to the right.
1. Select cells F6:G6.

2. Click: Home-> Alignment->
Merge & Center Dropdown->Merge Cells.

3. Repeat the process for cells H6:16, ]6:K6, L6:M6, N6:06, P6:Q6
and R6:56.

The first row of custom events should now look like this:

28 29 30 31 1 2 3

Dentist's
Appointment

4. Repeat the process for rows 9, 12, 15 and 18.

The last two days are a little different, because you have had to
add several extra rows to make room for the calendar settings. All
this means is that you will have to merge a few more cells for the
last two days.

5. Merge cells F21:G24 and H21:124.

A B C D E F G H | J K L M N (o} P Q R S|T
1]
2 {
3
4
5|
Dentist's
Appointment
6 {
7 4 5 6 7 8 9 10
8
Feed Cats
9 {
10 11 12 13 14 15 16 17
11
Jimmy's Birthday
12
13 18 19 20 21 22 23 24
14 Mart D
15|
16 25 26 27 28 29 30 31
17|
18|
19 1 2
20 | First Day of Week Monday
21| Show Moon Phases
22| Show Fixed Events
23 Show Custom Events
24|
25 |
26

6 Save the workbook as Year Planner-6.
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note

Getting more symbols

The symbols that are available
via the Symbols dialog are
provided by the fonts installed
on your computer. In this
lesson you're using the Segoe UI
Symbol font, which has been
automatically included with
every copy of Office (since
Office 2007) and Windows
(since Windows Vista).

If you need more symbols, you
can download additional fonts
from the Internet.

Always remember, however,
that custom fonts won’t be
available on other people’s
computers. If you send a
workbook to someone that
doesn’t have the same fonts as
you, they won’t see your
custom symbols.

For this reason, it's a good idea
to stay with the fonts that are
provided with Windows unless
you are the only user of the
workbook.

note

The new Segoe Emoji
font

Segoe UI Symbol was the default
icon font in Excel 2016. With
the release of Excel 2019
Microsoft have added the Segoe
UI Emoji font, which is
intended to replace Segoe UI for
many symbols, including the
moon phases used in this
lesson.

If you prefer the look of the
symbols in the Segoe UI Emoji
font, you can use it instead of
Segoe UI Symbol.

Year Planner-6

Lesson 2-9: Add moon phase
symbols

The next things you'll add to your user interface are the symbols for the
moon phases. Later you’ll make them automatically change according to
the date.

It isn’t possible to make photographic images appear and disappear
using an Excel formula. The solution is to use one of the many special
symbols that are available in Microsoft Office’s built-in library of fonts. It
will then be possible for an Excel formula to make any of these symbols
appear in a cell.

1 Open Year Planner-6 (if it isn’t already open).
2 Add a ‘new moon’ symbol to cell G4.
1. Select cell G4.
2. Click: Insert->Symbols—>Symbol.
The Symbol dialog appears.
3. Click the Font dropdown and select the Segoe Ul Symbol font.

You can now see the huge number of symbols that are
available. There are over 5000 different symbols in this font, so
it could take a very long time to find the ones you need by
scrolling through the list. Fortunately, you can take a shortcut
to the right place.

4. Click in the Character code box and enter: 1F311

You are instantly teleported to the New Moon Symbol entry,
which is highlighted near the top of the window. You can also
see the other moon symbols nearby.

Symbol ? X

Symbols  Special Characters

RO EE e D
OO0 00D ® IO 3 € @k« @
S Rk A e Y JB AL
VAR R AL ARG L AN

Recently used symbols:

Olud ©

Unicode name:

TM‘i|

o[e[o[o[c[3]e[e[¥[e]*

Character code: |1F311 | from: | Unicode [hex) |+

Insert Cancel

5. Click: Insert to insert the new moon symbol.

Mew Moon Symbal

6. Close the Symbol dialog by clicking the Close button.

7. Press the <Enter> key to confirm the entry of the new moon
symbol.
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28 @

Format Cells

Mumber  Alignment Font Border

Text alignment
Horizantal:
~| Indent:

Vertical: ﬂ =

The new moon symbol appears in cell G3, but it doesn’t look quite
right. This is because it has picked up the indentation that you
added in: Lesson 2-7: Apply text formatting.

Remove the indent from the moon symbol cells.
1. Select columns G, I, K, M, O, Q and S.

2. Right click one of the selected column headers and click:

Format Cells... from the shortcut menu.

3. Click the Alignment tab.
4. In the Indent box, type: 0
5. Click: OK.

The indent disappears.

Add symbols for the other moon phases.

Use the same process to add moon symbols to every day on the

calendar. When you get to the Waning Crescent Moon Symbol, start

again with the New Moon Symbol for the next day.

There’s no need to keep going back to the Symbol dialog after you

have inserted the first set of symbols. You can simply copy and

paste them once they’re on the workbook.

The moon phase doesn’t change every day in real life of course,

but this will be a good way of confirming that everything is

formatted correctly.

11

18

25

20 First Day of Week
21 Show Moon Phases
22 Show Fixed Events
23 Show Custom Events

O

12 ®

Jimmy's Birthday

19 4

26 o]

13

20

27

14

21

28

15

22

29

Dentist's
Appointment

16

)| 23

30

O

10

Feed Cats

17

24

31

O

5

Save the workbook as Year Planner-7.
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Lesson 2-10: Add a company
logo

The design concept shows a company logo in the top-left corner of the
calendar. You'll add the logo in this lesson.

1 Open Year Planner-7 (if it isn’t already open).
2 Insert the Smart Method logo in cells C3:D6.
1. Select cells C3:Dé6.
2. Click: Insert->Illustrations—>Pictures.

3. Navigate to your sample files folder and click
thesmartmethod.png.

4. Click Insert.
The Smart Method logo appears on your workbook.

5. Click and drag to move the logo to the top-left corner of the
workbook.

6. Click and drag the sizing handles to resize the logo as needed.

Al B C D E F G H |
1
2
3 MON TUE
4 28 ® ]
5
6
7 4 ® s L
8

3 Insert a text box containing the text thesmartmethod.com
1. Click: Insert->Text>Text Box.
2. Click below the Smart Method logo to insert a new text box.

Be careful not to click and drag as this will insert a text box
with a background color and border that you’d need to
remove.

3. Type: thesmartmethod.com
4. Click and drag to select the text that you have entered.

Alternatively, press <Ctrl> + <A> to select all text in the text
box.

5. Use the options in the Home->Font group to make the text
Arial Black, size 9, bold.

6. Set the font color to the standard color: Yellow

‘ Year Planner-7 |

48 https://thesmartmethod.com




Session Two: Create the User Interface

note

Standard colors are
not compatible with
themes

You might have noticed that
you're using a color from the
Standard Colors set in this
lesson, rather than the Theme
Colors set.

This means that the color won’t

change if the workbook’s
theme is changed, potentially
making the text hard to read.

You’'ve done this because the
image above the text is also

yellow and images can’t change

their colors to match the
selected theme.

If the workbook’s theme made
the company logo difficult to
see, it would be necessary to
either create a new logo image
or change the theme to a more
appropriate color scheme.

4

J Standard Colors

wny  More

Avial Black g A A == -
B I U- - O == 3=
Font B Automatic
Theme Colors
- E Em mn
C D E I
1T I

Vellow

7. Click and drag one of the edges of the text box to move it into

position below the Smart Method logo.

E F

A|lB C D
1
2
4
5
thesmartmethod.com
6
T

MON
28

You've now added the logo to the calendar. You could replace this
with your own company logo or any other image.

Save the workbook as Year Planner-8.

© 2018 The Smart Method® Ltd

49



Excel 2019 Construction Kit #1: Calendar and Year Planner

tip
Selecting form
controls

Form controls are usually
designed to respond to a left-
click with the mouse. For
example, left-clicking on a
Check Box control will check or
uncheck the check box.

Because of this, you can’t select
a form control by left-clicking
it. Instead, you need to right-
click to select a form control.

Jan

2016

Year Planner-8

Lesson 2-11: Add controls

Although you’re creating a non-functional user interface, it’s still useful
to add the controls that the user will use to change the calendar’s settings.
This makes it clear how the user interface works.

1 Open Year Planner-8 (if it isn’t already open).
2 Enable the Developer tab if it isn’t already visible.

1. Right-click any of the Ribbon tabs (except the File tab) and click
Customize the Ribbon from the shortcut menu.

2. In the right-hand pane, click the Developer checkbox.

Main Tabs
Background Removal

I Home

[+] Insert

[ Draw

Page Layout
] Fermulas
[+] Data

Review
View

HkDevelnper
Padd-ins

[] Help

3. Click OK.
3 Add Spin Button form controls to change the month and
year.
1. Click: Developer->Controls—>Insert->Spin Button (Form
Control).
Form Controls
O Ef @?EEI ®
[ 4a &

Spin Button (Form Control)
ActiveX Cowows—y ,\

O VM g
BloalRel

It's important to select the spin button from the Form Controls
section and not the ActiveX Controls section.

2. Click near the word Jan to create a spin button.

3. Right-click the spin button and click Format Control from the
shortcut menu.

4. Click the Size tab and set the Height and Width settings to: 0.5

Format Control 7 x

Size Protection  Properties AltText Control

Size and rotate

Height: 0.5 = Width: 0.5| 3
Rotation: |0° =
5. Click OK.
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tip
Perfectly aligning
form controls

To align the check boxes
perfectly you can use this
technique:

1. Right-click a Check Box
control to select it.

2. Hold down the <Shift> key
and right-click on each of the
other two Check Box controls
so that all three are selected.

3. Click:

Drawing Tools->Format—>
Arrange—> Align—> Align Left

You can see that there are also
many other alignment options.

First Day of Week

Show Moon Phases

Show Fixed Events

Show Custom Events

6. Drag the spin button into position next to the word Jan.

If you can’t move the spin button, remember that you need to

right-click on it to select it so that it can be moved.

7. Use Copy and Paste to create a copy of the spin button and
drag it into position next to 2016.

Add Check Box controls for the three check box settings.

1. Click: Developer- Controls=>Insert->
Check Box (Form Control).

2. Click near the words Show Moon Phases to create a check box.

3. Right-click the new check box and click Edit Text from the
shortcut menu.

4. Delete all text from the check box.

5. Drag the check box into place next to Show Moon Phases.

6. Copy and paste the check box and place the copy next to Show

Fixed Events.

7. Copy and paste the check box again and place the copy next
Show Custom Events.

Switch off gridlines.

to

Show Custom Events

Monday
Hiding the gridlines will make it easier to confirm that everything
is correct.
Click: View—>Show—>Gridlines.
F G H 1 J K L M N o P Q R s|T|u
MON TUE WED THU FRI SAT SUN
28 ® 2 ¢ 0 C a1 O 1 Ol 2 Qs i
thesmartmethod.com Dentist's
Appointment
4 ® s ® s e 7 C = C o9 Ol 10 o
Feed Cats
1 P 12 ® 13 ® 1 @ 15 © 16 C 17 0]
Jimmy's Birthday
18 O 19 > 20 ® 2 ® 2 o 2 C 2 C
25 O 26 Q 27 > 28 ® 2 ® =0 ¢ 31 C
1 O 2 o

The calendar interface is now fully defined. None of the controls
are functional yet, but you can see exactly how it will work and
where all of the information will appear.

Save the workbook as Year Planner-9.

© 2018 The Smart Method® Ltd
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Lesson 2-12: Create a table for
non-recurring custom events

The calendar user interface is fully defined, but you still haven’t defined
the interface for entering the events that will appear on the calendar.

There are two types of events: events that only happen once and events
that recur on the same date every year. You're going to define a table to
enter non-recurring events in this lesson.

1 Open Year Planner-9 (if it isn’'t already open).

2 Add a new worksheet named Custom Events.

1. Click the New sheet icon below the worksheet: L.~

A new worksheet named Sheet2 appears.

2. Right click the Sheet2 worksheet and click Rename from the
shortcut menu.

3. Type Custom Events and press <Enter>.

3 Rename the Sheet1 worksheet to Calendar.

Calendar | Custom Events )

Ready

4 Select the Custom Events worksheet if it isn’t already
selected.

5  Incell A1, type: Custom Events
6  Apply the Title style to cell A1.

1. Select cell Al.

2. Click: Home->Styles—>Cell Styles Gallery->Title.
7  Merge cells A3:B3.

1. Select cells A3:B3.

2. Click: Home~> Alignment->Merge & Center (Drop-
down)->Merge Cells.

8 In cell A3, type: Non-Recurring
9  Apply the Heading 2 style to cell A3.

1. Select cell A3.

2. Click: Home->Styles—> Cell Styles Gallery->Heading 2.
10 Enter data for non-recurring custom events.

Enter the following data into cells A5:B7, resizing the columns as
needed:

Year Planner-9 |
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11

note

12
The many benefits of
Tables

A Table defines a data table
within Excel that can grow and
shrink as rows are added to it
or removed from it.

A B C
Custom Events

Non-Recurring

Date
02-Jan-16 Dentist's Appointment
10-Jan-16 Feed Cats

MName

(== B~ I SO TR SR

Define the custom events data as a Table.
1. Select cells A5:B7.

2. Click: Insert->Tables—>Table.

3. Click: OK when prompted.

Non-Recurring

pate B Name -
02-]an-16 Dentist's Appointment
10-Jan-16 Feed Cats

[ R P

The colors change, and filter arrows appear, indicating that a Table
has been defined. This Table is the area where users will input the
custom events that need to appear in the calendar.

Because it’s been defined as a Table, the Calendar’s formulas will
be able to work with its contents even if rows are added or
removed (see sidebar).

Set the name of the Table to: CustomEvents
1. Click anywhere in the Table.
2. Click: Table Tools=>Design->Properties—>Table Name.

Tables enable you to create
formulas that refer to the entire
contents of the table without
them having to be adjusted

Table Name: Summarizewith PivotTable
Tablel I H‘H Rermove Duplicates |

& nsert
' Resize Table %Converttn Range Slicer

Properties Tools
Table Name
5 Feed Cat
Edit the name of this table used to
refer to it in formulas. C

when more data is added. This
makes data entry much more
user friendly.

Tables also enable you to use
Structured Table References in
your formulas. Structured
Table References can make
your formulas much more
intuitive and easier to maintain.

13

A Table can be beneficial in
almost every case where you
have a range containing data in
a tabular form within Excel.

14

3. Type CustomEvents and press <Enter>.

You've now named your table so that it can be easily accessed by
the formulas that you will create later.

Resize the table so that each column is wide enough to fully
display the contents.

1. Select cells A5:B7.
2. Click: Home—>Cells>Format—-> AutoFit Column Width.
The column widths are perfectly sized.

Save the workbook as Year Planner-10.

© 2018 The Smart Method® Ltd
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Lesson 2-13: Create a table for
recurring custom events

Recurring events are events such as birthdays that recur on the same date
every year. In this lesson you'll add a table to enable the user to define
recurring events.

1 Open Year Planner-10 (if it isn’t already open).

2 Select the Custom Events worksheet if it isn’t already
selected.

Merge cells D3:E3.
In cell D3, type: Recurring
Apply the Heading 2 style to cell D3.

o O bW

Enter data for recurring custom events in cells D5:E6 and re-
size columns D and E as needed.

A B C D E
Custom Events

]
2
3 |Non-Recurring Recurring
4
5

Date ﬂ Name v Date Name

6 | 02-Jan-16 Dentist's Appointment 12-Jan-16 Jimmy's Birthday
7 | 10-Jan-16 Feed Cats

7 Define the custom events data as a Table.
1. Select cells D5:E6.
2. Click: Insert>Tables>Table.
3. Click: OK when prompted.

D E

Recurring

3
4
5 PEIG ﬂName N
6

12-Jan-16 Jimmy's Birthday

The colors change and filter arrows appear, indicating that a Table
has been defined. This Table is the area where users will input
recurring custom events that need to appear in the calendar.

Because it’s been defined as a Table, the calendar’s formulas will
be able to work with the table’s contents even if rows are added or
removed.

8 Set the name of the Table to: RecurringEvents

‘ Year Planner-10 |
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2. Click: Table Tools=>Design—>Properties>Table Name.
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9

Table Name:

*I:l' Resize Table
Properties
Table Name

Edit the name of this table used to
refer to it in formulas.

Summarize with PivotTable
Tablel I H‘H Remove Duplicates

% Convert to Range

Insert
Slicer
Toals

5 Feed Cat]

T

3. Type RecurringEvents and press <Enter>.

You’'ve now named your table so that it can be easily accessed by
the formulas that you will create later.

A B

Custom Events
‘ Non-Recurring

Date - Name v
| 02-Jan-16 Dentist's Appointment
| 10-Jan-16 Feed Cats

P N OO U1 A W N -

-

Recurring

12-Jan-16 Jimmy's Birthday,

The user interface is now complete. All of the areas where users
will enter data have been defined.

Save the workbook as Year Planner-11.

© 2018 The Smart Method® Ltd
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anecdote

How my user
interface presentation
was mistaken for the
finished application

Several years ago, I created a
business intelligence
application for a pan-European
finance company.

Each country had already
signed off on the functional
specification and a meeting was
arranged in Rome for a
presentation of the user
interface for representatives
from each European country.

The meeting was quite
interesting as many of the
executives didn’t speak English
and had brought their own
personal interpreters (wWho
quietly whispered in their
boss’s ear as I spoke).

I'had put together a
PowerPoint presentation that
was arranged as a series of
screen grabs so that drop-down
menus appeared to work as I
clicked upon them (I had to be
sure to click in the right place
on the slide to make the illusion
work).

During the question and
answer session, one executive
wanted to know when the
application would be finished. I
had prepared a project plan
that suggested around three
months development time.

The executive replied that the
application seemed to be
already finished so could I
deliver it in the present state so
that he could start using it
straight away.

Perhaps something was lost in
translation. He had believed
that I was demonstrating the
finished application. I had to
explain that he had only been
viewing a non-functioning
user-interface design.

Year Planner-11

Lesson 2-14: Package the user
interface for review by users

You've now completed the user interface.

Your users have already signed off on the functional specification that
defined each feature the application had to deliver.

Because the user interface is non-functional it is important to convey to
users what each of the controls will do in the finished application. You'll
do this by adding callouts.

The user interface can then be circulated amongst end users for feedback.

1
2
3

4

Open Year Planner-11 (if it isn’t already open).
Select the Calendar worksheet.

Add a white oval speech bubble shape to the right of the
month shown in the indigo sidebar.

1. Click: Insert->Illustrations—>Shapes->Callouts>
Speech Bubble: Oval.

2. Click to the right of the date shown in the left-hand indigo
sidebar.

An oval speech bubble appears.
3. Make sure that the speech bubble is selected.

4. Click: Drawing Tools->Format->
Shape Styles Gallery->Theme Styles—>
Colored Outline — Black, Dark 1

This is the first style and is shown on the top left of the gallery.

Theme Styles

Colored Outline - Black, Dark 1 .
_L | 1 |

Resize and position the Speech Bubble and add text so that
it looks like this:

Abc Abc

These controls can be used to
change the month and year that
are displayed on the calendar.

18 O 19 D 20

1. Click on the Speech Bubble to select it and click and drag any
of the sizing handles to re-size. You can also use the yellow
handle to size and re-position the Speech Bubble’s arrow.

2. Click in an empty part of the Speech Bubble until you see the
four-headed arrow cursor shape and then drag to re-position.
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